What Recommended Specification devices if i play LYTOmobi games?

LYTOmobi games can be runs on Android and iOS devices, but some games in LYTOmobi still not available in iOS. The recommended system specifications for LYTOmobi games are below. Due to potential programming changes, the recommended system requirements for LYTOmobi games may change over time.

iOS Devices:
Games in LYTOmobi apps just will work on iOS 8 or higher for the following devices

    iPhone 4 and above
    iPad 2 and above, including all iPad Mini and iPad Air models
    iPod touch 4th Generation and above

To find out what operating system is on your iPhone, iPad or iPod touch please follow these steps:


    Access the ‘Settings’ button on the Home screen
    press ‘General
    Go to ‘About


If you need to update your iOS, connect your device to your PC and update via iTunes.


Android Devices:
We recommended games in LYTOmobi to you for using Android version 4.4 or higher, with a recommended screen resolution of 720 x 1280.

recommendet-new.jpg

To find out what operating system is on your Android device, please follow these steps (or follow the device manufacturer's instructions):


    Access the ‘Settings’ button on the Home screen
    Go to ‘About Phone
    Select ‘Software Information


If you need to update your Android operating system, check for 'Software Updates' or follow the device manufacturer's instructions.

Note: The Asus Transformer Pad TF300T and all Tegra 2 chipsets are incompatible with LYTOmobi games. Devices with PowerVR 540/544 GPUs may experience graphical issues. Updating your device to the latest version of your operating system may address these issues. Android 5.0 (Lollipop) or better are recommended.

Still have a question? Contact Us